Beta of Web Safety 4.0 (qlproxy) is Ready for Download

The Beta of next Diladele Web Safety (qlproxy) 4.0 is ready to download. This version contains the following features and improvements:

  • Fixed ICAP error when filtering headers of HTTP response. It is still recommended to have the icap_service_failure_limit -1 line in your squid.conf file (just in case).
  • Fixed incorrect purging of stale monitoring data in SQLite deployments
  • New and very much improved Web UI that will serve as a basis for all future additions. We now have place to implement most (if not all) features for managing not only qlproxy’s settings but also Squid’s settings from the Web UI. Hopefully in future you will seldom need to manually change the conf files.
  • Improved management of policies. It is now possible to clone existing policy when creating a new one. It is also possible to manage list of blocked categories, adblock and privacy subscriptions from within one page, reducing the overall number of clicks required to fully configure a policy.
  • New image filtering module (experimental). It is now possible to analyze JPEG pictures for skin color and block most of explicit images. Status of this feature is experimental so please do not use it in production environments yet. We are very eager to hear your ideas about quality of detection and still adjusting the heuristics to lower false positives.
  • Improved Surfing Now and Monitoring page. It is now possible to filter and group the monitoring records by user, domain, ip and top level domains. More info is stored in the monitoring database that acts as the basis for improvements in reports planned for 4.1 or 4.2 versions.
  • HTTP/HTTPS requests are now scanned too. This allows for filtering of explicit adult search terms in all search engines (including Google images).
  • Added support for viewing only school approved YouTube images using YouTube for Education subscription id.
  • Added support for using only specific domains in Google Apps for Business and Google Mail.
  • Various improvements in HTML deep inspection module (less false positives)
  • Support for Django 1.6.8

FreeBSD builds are now present as well as support for pfSense 2.1.5. Please download and see if this version good for your filtering environments. The code is now at freeze point and there are no open bugs. Release is planned for early January.

BTW – we now have the Squid for Windows site – squid.diladele.com. The idea is to provide everything necessary to run latest Squid build in Windows environment with native web filtering ICAP server. For now only 3.3.8 build of Squid from CygWin is available. Please take a look at the GitHub project https://github.com/diladele/squid3-windows if you are interested.

Best regards,
Diladele Dev Team

About sichent

sichent
This entry was posted in Diladele, ICAP, Windows 8. Bookmark the permalink.

2 Responses to Beta of Web Safety 4.0 (qlproxy) is Ready for Download

  1. Tomaz says:

    Hi, do you support pfsense 2.2 x64?

    Will you add support for tls 1.2?

    Why do you use SHA1 for ssl certificate and not sha256?

    Thanks for all replay

    • sichent says:

      Hello Tomaz,
      The pfSense 2.2 is not supported yet, we are waiting for it being released to start working on new packages system from FreeBSD upon which it is based. Our product itself does not do any SSL related staff so I cannot answer the following two questions. It depends on the Squid part 😦

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s